Insecure dependency in require while running setuid ....

| 迴響(1)

些許時間沒有看 awstats apache logs 統計的結果了,今天心血來潮 Firefox 一連, 就來個 伍佰 Internal Server Error 看樣子前兩天整理的 W3C http status code definations馬上派上用場
看了看apache的 error 後,如下

[Tue
Dec 14 13:19:34 2004] [error] [client 127.0.0.1] Insecure dependency
in require while running setuid at
/home/apache/cgi-bin/awstats.pl line 1370., referer:
http://foo.com/cgi-bin/awstats.pl


[Tue Dec 14 13:19:34 2004] [error] [client 127.0.0.1] Premature end of
script headers: awstats.pl, referer:
http://foo.com/cgi-bin/awstats.pl




心想是不是程式錯誤, 為何之前跑得好好的現在出錯, 想了老半天, 乾脆到官方網站再把最新
awstats-6.3 版 下載回來使用, 設定好了之後, 瀏覽器重新載入頁面, 又是一個伍佰 .

仔細思考了很久, 檢查了各版本
apache 2.0.52
awstats 6.2
perl 5.8.5
FreeBSD-5.3R
咦! 難道是之前升級 FreeBSD 5.2.1 到 FreeBSD 5.3 的關係
半猜測的情況下, 從 ports 重新安裝了一次 perl5.8
Bingo! 正常了!

迴響(1)

其實確認一下/bin/perl是不是被設定suid

發表迴響

關於此日記

此日記由 Gong 發表於 December 14, 2004 10:14 PM

此Blog上的上一篇日記田宮模型膠水

此Blog上的下一篇日記燃燒吧!! Firefox

首頁彙整頁可以看到最新的日記和所有日記。

彙整

頁面

Powered by Movable Type 4.37